Which mobile phones are compatible with Polar Loop?

Polar Loop's optional mobile companion, the Polar Flow app, is compatible with Apple’s iPhones, starting with iPhone 4S.


With Android platform you will need Android 4.3 or newer and one of the following devices:

  • Samsung Galaxy S5
  • Samsung Galaxy S4
  • Samsung Galaxy S3
  • Samsung S4 Mini
  • Samsung S5 Mini
  • Samsung Galaxy Note 3
  • Samsung Galaxy Note II
  • LG Nexus 5
  • LG Nexus 4
  • LG G2
  • LG G2 Mini  
  • LG G3
  • LG L90
  • LG L70
  • LG F70
  • HTC One
  • HTC One Mini
  • HTC One M8
  • HTC One Mini 2
  • HTC One Max
  • Motorola Moto X
  • Motorola Moto G
  • Sony Xperia Z1
  • Sony Xperia Z2

We will add more devices as we test them.

Was this helpful? Yes No