Selected Product
Polar Flow app
(change)

FAQs

Polar Flow app compatibility with Polar Loop

You need a Polar Loop activity tracker to use the Polar Flow mobile app. Also, your Polar devices must be first taken into use with a computer before they can be paired with the Polar Flow mobile app.


Polar Flow mobile app for iOS needs Apple’s iOS 7.0 or later. It's compatible with Apple’s Bluetooth Smart compatible devices:

  • iPhone 4S
  • iPhone 5
  • iPhone 5C
  • iPhone 5S
  • iPod touch (5th generation)
  • iPad (3rd generation and newer)
  • iPad mini (1st generation and newer)
  • iPad Air

Polar Flow mobile app for Android is compatible with following Android Bluetooth Smart compatible devices running Android 4.3 or later:
The Android app can be used only with Polar Loop activity tracker.

  • Samsung Galaxy S5
  • Samsung Galaxy S4
  • Samsung Galaxy S3
  • Samsung S4 Mini
  • Samsung S5 Mini
  • Samsung Galaxy Note 3
  • Samsung Galaxy Note II
  • LG Nexus 5
  • LG Nexus 4
  • LG G2
  • LG G2 Mini  
  • LG G3
  • LG L90
  • LG L70
  • LG F70
  • HTC One
  • HTC One Mini
  • HTC One M8
  • HTC One Mini 2
  • HTC One Max
  • Huawei Y530
  • Motorola Moto E
  • Motorola Moto X
  • Motorola Moto G
  • Sony Xperia Z1
  • Sony Xperia Z2


​We will add more devices as we test them.

Was this helpful? Yes No