Polar Flow app compatibility with Polar V800

Polar V800 is compatible with Polar Flow app v.2.0 and later for iOS only.


For now there is not a V800 compatible Android version of the Flow app available. 


You’ll need iOS 7.0 or newer and one of the following iOS devices:

  • iPhone 4S
  • iPhone 5
  • iPhone 5C
  • iPhone 5S
  • iPod touch (5th generation)
  • iPad (3rd generation and newer)
  • iPad mini (1st generation and newer)
  • iPad Air

Was this helpful? Yes No